0

Apple HomePods not connecting to internet

Starting on or about October 7, 2021, my Apple HomePod and HomePod mini have both been experiencing multiple intermittent issues with connecting to the wider internet (no issues connecting to the router). The issue appears to be DNS related as temporarily changing the DNS provider to the ISP resolves the problem. 

 

I haven’t  changed any configuration settings (on the router, NextDNS website or HomePod) recently that would appear to have caused this issue. It just suddenly started happening. Eventually, both the HomePod and HomePod Mini connect to the internet — only to disconnect after a while. 
 

In the NextDNS logs, there are no blocked logs (i.e. HomePod will try accessing the internet, report that there is no connection, but last blocked log in NextDNS is from an hour or more ago and is unrelated to Apple) . 
 

I’ve tried disabling all block lists in the NextDNS portal, soft resetting the Eero router, and restarting both HomePods (that are located next to the router or within 10 feet of it). Notably, no other devices (including other Apple devices like computers, phones, Apple TV, etc.) have any issues connecting to the Internet (even at the same time as HomePods can’t). 
 

I have an Eero 6 router and a Raspberry Pi running NextDNS CLI. 

 

Any suggestions? 

2replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • I wrote a long response and then realized your router was an Amazon brand that charged 10$ a month for Dynamic DNS someone must really be greedy to add a basic router function then charge you like it's something special. Anyways, if you have a static IP I really hope you do, with that router. Pointing the DNS to NextDNS and using the link option in my.nextdns.io should hopefully fix it.

    Using a Raspberry PI is iffy at best, I saw people talking about how it wouldn't properly get an IP for devices if the Router / Rasp boot up time wasn't the same and a lot of weird issues, so stopping any possible points of failure should help. Try that and see if it improves yours situation.

    Like 1
      • N K
      • N_K.1
      • 1 mth ago
      • Reported - view

      Hey thanks for your tips. I tried your suggestions as well as other possible solutions (having the DNS connect directly to NextDNS from router settings without utilizing the NextDNS CLI on the Raspberry Pi at all, having a different DNS provider (1.1.1.1 worked but 1.1.1.2 did not), resetting the HomePods, turning off all NextDNS block lists and security settings from the website, etc.)

      Unfortunately, none of those changes worked. However, it appears that iOS 15.0.2 has fixed the problem. As I’ve learned, HomePods update their internet settings based on your iPhone internet (Wi-Fi) settings, and more frequently than just during the initial setup. Since I didn’t change any other settings (anywhere on the network or on the devices) except for the iOS 15.0.2 update, I assume it was the iOS update that fixed the problem. 

      Like
Like Follow
  • 1 mth agoLast active
  • 2Replies
  • 59Views
  • 2 Following