NextDNS not working when Surfshark VPN is active

Hi guys!

I am having a little bit of trouble with Surfshark VPN and NextDNS working together on my iPhone 13 Pro Max.

Are there any settings I need to make in order to have them work?

Whenever Surfshark VPN is on, I keep getting a status notification in my NextDNS control panel that the device is using some other DNS resolver.

When I turn Surfshark VPN off, the dot turns green, ie NextDNS is my DNS resolver on the iPhone 13 Pro Max.

I am using the NextDNS app, but also tried to set up the downloadable profile from the Apple Configuration Profile Generator. But it still doesn't work.

Would you be so kind to help me out?


3 replies

    • Nicholas_Spagnoletti
    • 1 yr ago
    • Reported - view

    i have similar problem: surfshark VPN does not work when i have my DNS servers configured to nextDNS. (surfshark connects to its VPN service, appears to work, but no domains can be resolved while connected) I am not sure if I need to add some surfshark domains to whitelist or not, unclear whether the problem is with nextdns or surfshark.

      • Hey
      • 1 yr ago
      • Reported - view

      Nicholas Spagnoletti I had used a trial of SurfShark like a year ago through NextDNS using Private DNS or the Windows app and that worked perfectly so I'd recommend the same.

    • Nicholas_Spagnoletti
    • 1 yr ago
    • Reported - view

    using ubuntu linux so the windows app is not an option for me.

    not sure what you mean by Private DNS, is that some product?

    if i remove nextdns settigns from my resolved.conf in systemd, and revert to either google dns or my ISPs DNS, then surfshark works fine. but it is a faff to have to change the DNS settings in systemd resolved.conf everytime i want to use surfshark.

Content aside

  • 1 yr agoLast active
  • 3Replies
  • 679Views
  • 3 Following