NextDNS not working on cellular mobile data


was happy to find this app and went directly to be a pro customer :)

I use an iPhone on Tmobile USA and next dns engages when on a wifi but the moment the wifi is turned off and on cellular the app tells me it’s on but a quick look at dns leak webpage tells me I am hitting a bunch of Tmobile dns ...

How can I solve the issue?

7replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • I also ran test.NextDNS.il and it tells me :

    ‘status unconfigured  which is bizarre 

    pouvez vous m’aider les proprios ? :) merci!

  • Are you using the app or the generated profile on ios?

      • Francois G
      • Francois_G
      • 8 mths ago
      • Reported - view

      Olivier Poitrey  I have used both tried it for a few days with one, then the other, and even both together (but cannot be enabled  together.

      weirdly the behavior is uneven sometimes it works but most Time it doesn’t. The mynextdns states that it used T-Mobile numerous dns (dns leak shows the same) however when it works I can see the login in in the logs. I am at loss to explain it. The same random behavior is also occurs g when starting a vpn.

  • I use the generated profile and it works perfectly fine on iOS when outside the home network on 4G LTE.

  • I seem to have the same problem on my iPhone. I currently use the app but earlier also tried the generated profile. Sometimes it works and it uses NextDNS on cellular data but a lot of times, it doesn’t and just uses the dns servers from the cell company (In this case, Verizon). I verify dns by logging onto the NextDNS site and it states “This device does not use NextDNS” even though the app is enabled. However certain times, it works. 

  • I have the same issue. When I am on mobile data, nextdns doesn't do anything (even if the app is installed). When I am on WiFi, it is working just fine.

    I am using a Xiaomi Mi9 as a mobile phone.

  • Are you using a personal VPN, more specifically one with an IKE VPN profile installed? 

    I had the exact same issue where it would work on wifi but not on cellular data. Tried a couple of things suggested in other forums (in the Advanced settings of Apple Config Generator, enable BootStrap IP) but wouldn't work.

    Finally got to the root of the issue (in my case). I'm using a VPN and it won't work when an IKE VPN profile is installed on the phone. After I deleted the IKE profile, it works like a charm on cellular or wifi. 

Like Follow
  • 2 mths agoLast active
  • 7Replies
  • 341Views
  • 5 Following