0

NextDNS setup with pfsense (I need help with full tutorial)

If I do the following steps I'll not get the device name. I'll get as unidentified devices

pfSense

1. Go to Services → DNS Resolver and on the tab General Settings scroll down to the Custom Options box.

2. Enter the following lines:

server:
  forward-zone:
    name: "."
    forward-tls-upstream: yes
forward-addr: 45.30.30.30#XXXXXX.dns1.nextdns.io
    forward-addr: 2f06:b8f0::#XXXXX.dns1.nextdns.io
forward-addr: 45.30.30.30#XXXXX.dns2.nextdns.io
    forward-addr: 2f06:b8f2::#XXXXXX.dns2.nextdns.io


I tried to ssh the pfsense and run the sh -c 'sh -c "$(curl -sL https://nextdns.io/install)"' it will install the application but still shows spectrum is your DNS resolver.

 

Thank you!

2 replies

null
    • Angelo_Restrepo
    • 1 yr ago
    • Reported - view

    Thanks for those instructions and worked for me. I do have a question for those that use pfsense like I do. How to I make the firewall use Wireguard VPN Dns instead of using Nextdns? I have both Wireguard and unbound custom option enabled and haven't been able to figure it out. Nextdns sends SNI in plain text correct? When using a VPN this info should also be encrypted correct?

    • Matt.5
    • 10 mths ago
    • Reported - view

    I too have a more complex setup, I have several VLANS configured in PFSense, and I want each of them to correspond to a separate profile in NextDNS. I've been able to get it to work using the Linux version of the NextDNS client installed on PFSense, with some complex config... but it doesn't feel very robust and it isn't well integrated with PFSense. I'd really like to see a better solution here.

Content aside

  • 10 mths agoLast active
  • 2Replies
  • 2128Views
  • 3 Following