Can't delete NextDNS profile from macOS Network Preferences

I don't know why but I've mess something and now I'm unable to delete the nextdns profile from network prefs in macOS. I think I have deleted the profile without turning off the  dns service, so I've found the plist file but I'm unable to delete it.


I've already tried to install a new profile, then delete it and see if it deletes both the new and old dns profile, but no, it deletes only the new profile and its related dns preference. Not the old, even if I made a new profile with the same details as the old one.


Any help? Thanks

9replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Looks like a macOS bug. Which version of macOS are you running?

    • Olivier Poitrey Latest 11.3 from yesterday but also before the latest upgrade with 11.2.3 I was unable to delete it.

      Also to me looks a macOS bug...but now? How can I delete this old nextdns DNS profile? Do you have an idea? Thanks :)

    • Giulio Magnifico first time I see that so I’m not sure. You may want to report this to Apple.

  • Have you tried temporarily disabling SIP? That should allow you to delete any file.


  • Giulio Magnifico

    That type of profile is stored in a different location

    Got to System Preferences>Profiles

    and remove it from there ........

    EDIT: sorry my bad you already tried that!

    Have you simply tried restating the mac to see if it clears out the old network dns?

    In your network screen when the NextDNS is selected what options do you get clicking on the down arrow along side the + and -        to the bottom?

  • Giulio Magnifico

    HOW to manually remove a network service from a Mac

    In Terminal type networksetup -removenetworkservice “yournetworkservice”

    Instead of yournetworkservice, type the name of the network service you want to remove from your macOS device, using quotation marks. If you are not sure about its correct name, you can find it in the list of your network services.

    To view this list, go to Terminal: networksetup -listallnetworkservices

    Make sure that you typed the name of the network service exactly in the same way as it appears in the list.

    To ensure that the network service is removed on your macOS, you can view the list of network services again:

    Terminal: networksetup -listallnetworkservices


    Note. Only Terminal is required, no XCode. The .plist will update automatically; you don’t need to copy or delete it. The remove command bypasses the GUI and removes the service whether or not the  button is greyed out.

    Like 1
    • Terry Webbs Thanks but I don't have the NextDNS profile listed, I don't know why...

  • The software was deleted but the service can not be removed:

    xxxxxxx@Mini-van-JEJ ~ % networksetup -listallnetworkservices             

    An asterisk (*) denotes that a network service is disabled.


    Ethernet Adaptor (en4)

    Ethernet Adaptor (en5)


    Bluetooth PAN

    Thunderbolt Bridge


    xxxxxxx@Mini-van-JEJ ~ % networksetup -removenetworkservice "NextDNS"

    You cannot remove NextDNS because there aren't any other network services on IPv4.

    ** Error: The parameters were not valid.

  • Same issue for 5 months…i tried everything

Like1 Follow
  • 4 days agoLast active
  • 9Replies
  • 140Views
  • 7 Following