How to connect via the Android app?

Dear NextDNS experts,

I installed the NextDNS Android app on my ebook reader, an OnyxBoox Note 2 running Android 9. This is what it displays: 

I can tap on the wheel and change the settings, which I did for specifying my configuration. But it says "disconnected" and I see no way to change that. I tried tapping on all the elements, but except for the wheel, nothing reacts.

So... what does it take to connect?

4replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • What about the gray radio button in the middle to the far right? Have you tried pressing it or swiping it all the way to the left? Also have you tried rotating your ebook to landscape orientation to see if it resizes the app's elements more appropriately?

    Are you able to use private DNS instead since you're on Android v9?

    • Greg B. Thanks for your suggestions!

      That gray button is not part of NextDNS, but an overlay that provides quick access to important apps. I have tried tapping and swiping pretty much everywhere on the NextDNS app screen, but nothing reacts to anything, except for the wheel leading to setup.

      Unfortunately, my device runs a modified Android with severely reduced setup options. The only network options are Wifi / Bluetooth parameters and configuring a VPN. That's why I downloaded the app in the first place - on my phone, I used private DNS which works just fine.

      • Greg B.
      • nisten
      • 2 days ago
      • Reported - view

      Konrad Hinsen I'm not familiar with this model but it sounds like the manufacturer locked down or stripped down the OS. You might have to try a 3rd party DNS/VPN app like Nebulo from the Google Play Store and add custom DoT/DoH servers based on your NextDNS DoT/DoH endpoints

    • Greg B. Thanks a lot for the pointer to Nebulo. That one works just fine! The OS on my e-book reader is indeed stripped down in several places, e.g. no Play Store (because Google doesn't approve e-Ink devices). Perhaps the DNS settings were collateral damage. Anyway, I am up and running now!

Like Follow
  • yesterdayLast active
  • 4Replies
  • 39Views
  • 2 Following